Audio Dropouts/Pauses during playback

Describe your issue here:

I’m running into an issue that may be with ableton and may be with ableset but TBD. Essentially, my timeline is very long. There’s something like 77000 measures in the session. Towards the end of the session, certain songs will have a temporary pause/gap in playback. Instead of skipping forwards or backwards, is almost like there is a temporary pause and then playback picks up right where it paused. CPU is extremely low and I’m getting no disk errors or CPU spikes.

I’m on a Mac M1 2021 with 32gb ram on Monterey.
Ableset is version 2.3.0 on Ableton live 11.3.4

@Connor_Ehman thank you for reporting this!

I’ve actually seen this issue as well, but it happens so sporadically that it’s super hard to debug. AbleSet runs on a different thread that’s separate from audio playback, so I don’t think it’s causing this issue. So it’s likely either a bug in Live or in macOS’ audio drivers.

I’ve also seen this with different buffer sizes, different audio interfaces (Scarlett 18i20, PlayAUDIO12, X32 USB, RME DigiFace Dante), and different versions of macOS over the past few years.

I’ve noticed that this issue is more likely to occur the longer my MacBook has been running. Usually, I never turn it off and just put it into sleep mode, but I’ve started restarting it once before sound checks and that has worked so far.

If anyone else has had this issue, I’d love to hear about your experience. You could also try contacting Ableton to see if they’ve seen similar issues before and have ideas for how to fix this.

That makes sense to me. In your experience was this just across the timeline in any position or specifically towards the end of the timeline in a very large session? I’m only noticing it past something like bar 50000 or so.

One of the reasons the bar count is so high is because the previous engineer on this gig set the meter to 1/4 which then created the excessively high bar count. Was curious if this high number is something that is hard for ableton to read or if it has to do with just the volume of audio in the actual session.

Hi mate, i had the same issue, with a Mac M1, 16gb. It is the buffer size in Ableton, reduce your buffer to 128, it fixes the issue. I have nearly 200 tracks in 1 time line it is massive, no problems anymore. It is to do with the Mac using its physical processors rather than it’s software processors. Let me know if that works for you. Certainly did for me.

Interesting, which version of ableton were you on?

Same as ops, same rig except for RAM, The M1 is a beast, eats this stuff but the buffer can be flukey with playback.

I hear you, I guess what I don’t understand is why making the buffer lower actually gets rid of the issue instead of raising the buffer

The way it was explained to me is: The processing power in the M1 is divided between mechanical processing which is more powerful, and software processors which are not as effective but are what the M1 defaults to mostly, by lowering the buffer you are forcing the mechanical processors into action, which actually work better. Regardless, it worked for me, i am running tracks, and it was gliching like yours, not a lot, but even once at a gig is too often, and now it is flawless. I also hear that for some issues, running ableton in Rosetta helps.

I’ve experienced this again today during rehearsals and we’re using a buffer of 128 samples already, on an M1 Max MacBook Pro running Live 11.3.4 and Ventura 13.3, using a DigiFace Dante for output.

Maybe there are multiple different reasons for these dropouts. If you remember the date and time those dropouts occurred on your machine, could you email me a log package to You can create one by clicking “Create Log Package” in AbleSet’s settings menu.

Maybe I can find some similarities between our logs that could bring us closer to finding a solution.

Sure can! I went ahead and downgraded my session to 11.2.11 though. I will let you know if it happens again though. Do you know what bar number you were on when you had your dropouts? Additionally, did your dropout get recorded? I would love to know if your dropout was a skip, a pause, or a dropout that resumed in time. For me, it was what looked like a 50ms pause that picked up right where it left off which is what threw the band out of time.

I’m currently using Live 11.3.4, but I’ve had those dropouts since Live 10. They’re always a kind of pause, like you described, between 50-250 ms I’d say. I don’t have a recording, unfortunately, but I’ll try to think of that for our next rehearsal.

EDIT: The dropout occurred somewhere between bar 1008 and bar 1093 in my session.

I have a log from my dropouts I can give you the time at least within a few hours & the date obviously.

1 Like

Okay interesting so perhaps bar count is not a factor like I originally thought.

A few more interesting things I noticed when this happened:

  • Live’s CPU meter didn’t spike and wasn’t orange, like what you’d usually see when the CPU is overloaded due to the buffer being too small
  • There are no entries in Live’s log during the time that the dropout occurred. About 30 minutes before the issue occurred, Live logged the following:
    info: CoreAudio: Device init: Leo Bernard’s iPhone Microphone (1 In, 0 Out) (Apple Inc., Id: 125, UniqueId: 38423942-0000-0000-0000-000000000003)
    Not sure whether that’s related to the dropout, but could be interesting

@Connor_Ehman has downgrading Live helped on your end?

Yes I’ve noticed the same. I’ve even been monitoring the CPU usage from several different applications and none seem to indicated any CPU spike. I also have never seen a “disk error” or anything of that nature.

In regards to downgrading I’m not going to give it the 100% stamp yet but I did run 1 full show now with zero pauses. If I make it another 3-4 shows without one I think it’ll be safe to assume it was at least part of the problem.

That’s good to hear, I’m looking forward to your feedback after the next few shows!

I’ve also contacted Ableton about this but haven’t received a response yet. I’ll let you know when they answer.

I just posted this issue on the /r/ableton subreddit, maybe someone there has experienced a similar behavior or found a potential fix: Audio Pauses Sporadically for a Few Milliseconds During Playback

Feel free to add your experience if you like :slight_smile:

Nice one, ill hop in there. Thanks man

Ableton just released Live 11.3.10, I’ll test this new version today to check if that fixes the issue on my end.

I made three changes to our setup that seem to have fixed the issue for now:

  • Increased the buffer size to 256 samples
    • Not sure if that’s really necessary, but it didn’t hurt in our case
  • Disabled Continuity Camera on my iPhone (General → AirPlay & Handoff)
    • This caused a virtual microphone to be added to the computer’s audio devices every time my iPhone came near my MacBook, which might have been one of the causes of the dropouts
  • Ensured that I don’t use AU & VST versions of the same plugin in my project file
    • I had used AU & VST versions of FabFilter Saturn and moved them all to VST

I’m not sure which of these fixed the dropouts, but in the past few rehearsals, it all worked without any issues. I hope this helps anyone else experiencing this!