Using “+CLICK” and “+G:CLICK” Together in AbleSet 3

Before the latest version of AbleSet, I used the “+CLICK” flag to define tracks that belong to the click group (such as the metronome, count-in, loop guide, and guide), and so these tracks respond to certain MIDI and OSC messages.

With the introduction of track groups in AbleSet 3, I also added the “+G:CLICK” syntax so I can manage them from the mixer. However, I’m not sure if it’s correct or necessary to use both. For example, my guide track name now looks like this:

GUIDE +CLICK +G:CLICK

Is this the recommended approach for syntax, or should I only use “+G:CLICK” going forward?

Thanks!

Hey @agustinvolpe, that’s a good concern!

AbleSet treats +CLICK as an alias for +G:CLICK so the two behave exactly the same. You can use either one, depending on your preference :slight_smile:

1 Like

Hey Léo,

Thanks for your response!
If +CLICK is essentially an alias for +G:CLICK and they behave the same way, I was wondering if the same logic applied to other groups.

At first, I thought that instead of using +G:TRACKS, I could just use +TRACKS, but after testing it in AbleSet, it doesn’t seem to work that way.

So, +CLICK is just an alias for +G:CLICK, but +GUIDE and +LOOPGUIDE are not aliases for +G:GUIDE and +G:LOOPGUIDE, are they?
I understand that those flags are intended for playback solo/muting/looping purposes in AbleSet, because they don’t show up in the mixer, (at least as of this version).

The reason I structured the syntax the way I did was to ensure these tracks are correctly identified and all functions are available (in this case I needed to be able to both control my guide tracks’ volume -hence +G:CLICK -, and also having it be muted when a song is looping).
Could you clarify how these flags work in this case, or if this just applies to the +CLICK flag?
Maybe I’m getting some part of it wrong.

Sorry for being such a pain😅

Thanks again!

Hey @agustinvolpe,

You’re correct – only +CLICK is currently available as an alias for +G:CLICK for backwards-compatibility reasons.

I could also alias +GUIDE and +LOOPGUIDE to +G:GUIDE, but I had initially decided against it as I’m not sure everyone needs a Guide group in their mixer. What do you think?

Please let me know if you have any further questions :slight_smile: