Tempo Map interfering with drift correction?

Try as I may, I cannot make AbleNet work for me. I have followed all the setup recommendations to the letter, including only having drift correction enabled on the backup machine and setting the preferred connection on both computers to Ethernet.

The problem is, I can never get a tight sync. It’s always just a beat or so off when I toggle between scenes on PlayAudio12 or 1U. In fact, the only way I can achieve a perfect sync is through Ableton Link. Then I studied how drift correction works, and something occurred to me.

I have dummy audio clips set as the tempo leader throughout my set. Therefore, the tempo map is being governed by automation. Would following a tempo map be an issue for the “nudging” of the drift correction?

This is a segué into a feature request; it would be nice if AbleSet itself could govern the bpm by way of clip or a tag. This would save having to have the tempo track at all.

Update: Disabling drift correction, in my case, has made a significant improvement. The sessions seem to stay in sync now. I have a page in my Open Stage Control layout where I can watch both LTC displays in large type. I let my system play non-stop for 20+ minutes and it very rarely ever lost sync. Even when it did, it seemed to correct itself within a few beats, even with Drift Correction turned off!

Hey @mrdrennan,

That’s an interesting discovery! A few questions to clarify what might be causing Drift Correction to act incorrectly:

  • Are you using any form of MIDI sync in Live to sync your B computer to the A one?
  • Are the clocks on both computers in sync? (you can check this here)
  • Does the delay between both computers feel consistent when using Drift Correction, e.g. always ~200ms or ~1 beat?

I’m looking forward to your reply!

Forgive the delay; no MIDI sync from one computer to the next, only clock out to hardware. Both clocks are perfectly in sync, according to the link. I can’t say if it’s exact, what I can tell you is that the problem has been resolved since turning off drift correction on both computers.

Thank you for your feedback! I haven’t managed to reproduce this issue on my end yet, unfortunately, but I’ll keep trying and looking for a fix.