MIDI control behaviour with HX Stomp

I’m currently running into the following issue, and I cannot seem to find a workaround.
Just to be clear, I’m not putting the blame on AbleSet here, I’m not really sure if this is a problem on HX’s side or Ableton, or AbleSet, or something in my particular setup.

I currently have my HX Stomp’s footswitches programmed to control AbleSet in MIDI channel 16, and my patch changes for the same device on an Ableton MIDI track, on channel 1.

This is what my MIDI mapping on AbleSet looks like:

This is the MIDI track for patch changes on Ableton Live, which outputs on MIDI channel 1:
Captura de Pantalla 2024-05-02 a la(s) 16.44.37

So, when the MIDI patch-changing track on Ableton is muted, navigation through the set list is fluid, no hiccups whatsoever.
But when I unmute the patch changes track, strange things start happening, such as songs being skipped or being unable to select some of the songs on the list.
I opened up the MIDI monitor to look further into this.
In this first video we can see in the MIDI monitor, that for each full press (meaning press and release) on a given footswitch, 2 outgoing messages are sent: Note on and Note Off👇

Now take a look at this second video where we can see that upon unmuting the patch changes track on Ableton, messages sent from HX Stomp do not follow the Note On/Note Off pattern. Note how the 2nd song on the setlist is skipped, and the information on the MIDI monitor:

It is my understanding that upon unmuting, and as the playhead hits a given MIDI patch, Ableton sends whatever PC & CC that I got dialed in for my patch changes. And while that’s intended, I think there’s something -presumably a CC issue- that’s making the HX Stomp or AbleSet behave like this, or clashing in some way.
For additional context, the CC used for changing scenes on the HX Stomp -which might be causing this- is CC69 (under the name of “Hold 2” in Ableton’s envelopes). These MIDI clips are placed right on the start of every song, where the locators and section clips are.

This is what the envelope’s CC edit for the 2nd song on the 2nd video (the song that is mistakenly skipped) looks like:

I think it’s something to do with the CCs described before.
I can also provide the log package if needed.

Any help would be greatly appreciated.


  • macOS Big Sur 11.7.10
  • AbleSet 2.2.6
  • Ableton Live 12.0

Try running the envelope to 127 and then back to 0 a beat later. I have a headrush and the cc’s need to replicate the action of pushing down the switch and then releasing. I hope this helps


That worked like a charm, life saver👌
Thank you so much!

You’re welcome. Glad to hear it worked. Cheers

1 Like