Lyrics Not Displaying And Jumping Away

Hi Leo

Firstly, thank you for creating AbleSet and continuing development on it. It really is a wonderful tool.

I have an issue / potential bug where AbleSet can’t display lyrics (at least initially) if the ableton session is inside a folder that has square brackets [ ] in the directory structure. e.g. “C:\Users\username\OneDrive\Desktop\AbleSet Testing\Artist Name - Song Title [Key - BPM] Project”.

If I have the file saved in a folder with parenthesis brackets e.g. “C:\Users\username\OneDrive\Desktop\AbleSet Testing\Artist Name - Song Title (Key - BPM) Project”, it seems to work just fine.

I’ve tried Mozilla Firefox, Google Chrome, Microsoft Edge and they all share the same outcome.

My second issue is that my lyrics pages seem to jump on the last section (most of the time) before a new page starts.

I’ve included a video going over my findings here, hopefully it will detail it a bit better for you.

AbleSet Testing

I’ve also emailed you all of my testing materials to the support inbox and a couple of log files of the session. One log file was taken when I first open the session and the lyrics do not display, the second log file was when I have opened another session, and then gone back to the first one and it displays it then.

OS and Version: Windows 10 Home 22H2 OS Build: 19045.3693
Version of AbleSet: AbleSet v2.5.0
Version of Ableton Live: Ableton Live Suite v11.3.3
I’m also using Firefox v119.0.1 (64-bit) to display AbleSet.

Kind regards

Hey @brendan19, welcome to the forum, and thank you for the thorough bug report!

I managed to reproduce the square brackets bug on my end and will release an update with a fix soon.

Regarding the 2nd part, this behavior is kind of expected, but for your use case where one page spans multiple sections, it can be annoying. The easiest solution to this is to disable the section headers by adding the [nosections] attribute to the lyrics track name.

I hope this helps. Let me know if you have any further questions or feedback!

1 Like

Hi Leo

Just following up on this because I found another issue.

Special characters such as an é in the folder structure will also cause lyrics images to not load.

I’ve seen this kind of bug in the past but thought I had already fixed it. Could you send me a log package so I can take a look at what might be causing this? You can create one by clicking on “Create Log Package” in AbleSet’s settings menu.

I’m looking forward to your reply!

I’ve just sent through a couple of log packages. One with the special character in the folder structure and one without it for you to have a look at.

Thank you for the log package! I think I found the issue and will release a fix for it soon. AbleSet watches Live’s log files to determine which project file is currently loaded, but there’s a bug in Live where special characters in paths aren’t logged correctly. For example, this path:

E:\AbleSet\Zhané feat. Fam - Hey Mr. D.J. (F# Minor - 101 BPM) Project\Zhané feat. Fam - Hey Mr. D.J. (F# Minor - 101 BPM).als

Is logged as follows in Live’s log files:

E:\AbleSet\Zhan� feat. Fam - Hey Mr. D.J. (F# Minor - 101 BPM) Project\Zhan� feat. Fam - Hey Mr. D.J. (F# Minor - 101 BPM).als

My workaround for this is that AbleSet tries to find a file on your computer that matches this path as closely as possible, while recognizing that those characters are missing information and could be any special character.

Hey @brendan19, I just released AbleSet 2.5.2 which should fix this issue. Could you try to update and report back on whether this works for you as well?

Hi Leo

This seems to be working just fine now! Thanks again :slight_smile:

1 Like