AbleSet and Dante - network


I’m touring with my band triggering tracks from my MacBook Pro M1 Max. I’ve had some issues connecting using local network and would like to try a wired one with dongles connecting my iPad to my MacBook.
But, we’re also sending the tracks via Dante out of my Mac. Will that be an issue or is there a way to deal with this?

Thank you!

Hey @Kristoffer_Lo, welcome to the AbleSet community!

I’m currently working with a very similar setup to what you describe, where we run AbleSet and Dante over the same wired network and I haven’t had any issues with this so far, even with latencies set as low as 1ms using RME’s DigiFace. AbleSet doesn’t use a lot of bandwidth so it shouldn’t cause any issues with Dante.

If you want to be on the safe side, you could use a separate Ethernet dongle on your MacBook to create a dedicated network for AbleSet so your Dante network doesn’t have to deal with any traffic caused by AbleSet.

I hope this helps, please let me know if you have any further questions!

We run the same setup and we have one dongle running a separate network and one running Dante. Have not had any issues with it.

1 Like

Hi @leolabs and @iamderkis
Thanks for the feedback - highly appreciated!
I do have some issues with getting a network up and running. I have connected my iPad to my MacBook (M1 Max) using two dongles (USB-C to Ethernet → Ethernet to Lightning). I have set up the Ethernet Network with IP address, turned off WiFi on both devices and the “Ethernet” menu appears on the iPad’s settings.
When I open AbleSet in my browser on the Mac, all is good. But when I try open http://Kristoffers-MacBook-Pro.local on my iPad, nothing happens.
If I turn on WiFi and connect using a hotspot, the page appears immediately. But I don’t want WiFi to be enabled.
What am I doing wrong?

Thanks again!

Hey @Kristoffer_Lo,

could you send me a screenshot of your Ethernet settings on both your iPad and your MacBook? It’s likely just a simple configuration issue :slight_smile:

Hi @leolabs
Thanks for getting back!
Here’s how my menus on my iPad and MacBook looks like:

Hey @Kristoffer_Lo,

Could you try changing the “Configure IPv4” option to “Manually” and enter the same subnet mask you have on your iPad ( That might solve the problem.

You could also try disabling the “Limit IP Address Tracking” option, though I don’t think it will make a difference.

Let me know if this helps!