AbleSet/Ableton not loading live sets

Yesterday when I was singing with my band AbleSet/Ableton suddenly took forever to load songs. We use multi-file with around 20-100 plugins for each song. This might sound like too many and thats where the problem lies and that we should use less. Maybe we should. But we have done over 40 gigs with this setup and with no issues. It usually takes 2-15 seconds to load a song depending on how much processing and thats where we take applauses and talk to the audience.

Yesterday in the morning before the show I installed the latest version of AbleSet it worked like a charm. Nothing out of the ordinary. In the middle of the day during the show the songs started to take very long to load and increasingly got worse. The last song before the show was over must have been 2-3 minutes. After the show I was trying to fix this problem and then when I loaded songs, most of the time Ableton would just load forever to the point of me force quitting the application.

I did this before it was “fixed”:

  1. I installed the earlier AbleSet version 2.2.5 because I didn’t have this issue before. Ableton still wouldn’t load live sets. I later installed the version 2.3.0 again.
  2. Tried to skip AbleSet and load songs in Ableton instead. Ableton still wouldn’t load live sets.
  3. Removed AbleSet as a control surface. This let me load songs directly form Ableton instead.

Today is a new day and we do a show this evening. I now added AbleSet as a control surface again and it works as intended. I don’t know what happened and I would like to ask you guys and Leo what you think could have happened.

  • Computer: Macbook Pro M1 Max
  • OS and Version: macOS Ventura 13.2.1
  • Version of AbleSet: 2.3.0
  • Version of Ableton Live 11: 11.2.11
  • Mixers: M32C usb card to computer (IEM) & X32 (FOH)
  • Plugins used: Waves F6, FF Pro-C 2, Waves RBass, Ableton Looper, Ableton Saturator, Waves Vocal Bender


PS: The only other problem we have had with this setup is an occasional Ableton crash when loading a song. In the report I understand it as an issue with waves but I’m not sure. This has happened 7 times since we started using this setup in February. It has happened 1 time during a show but was quickly reloaded without interrupting the show.

Hey Oscar,

Thank you for reaching out, I’m sorry to hear that you experienced loading issues with multi-file projects!

To further inspect what might have caused this, could you email me a log package including your project files? You can create one by clicking on “Create Log Package” in AbleSet’s settings menu.

There haven’t been any changes between AbleSet 2.2.5 and 2.3.0 in how projects are loaded, so it might not have been the update that caused the issue but something else.

I’m looking forward to your reply and hope we’ll find a solution soon!